How to install Transmission, the bit torrent client?


I’d like to install and use Transmission, the bit torrent client.

In my configuration.nix file, I have tried adding both transmission and transmission-qt. transmission-qt does add an app to my system that I can start. However, I can only ever add torrents but they do not start downloading.

Looking into other questions on this forum, I have the following options:
services = { transmission = { enable = true; user = "transmission"; group = "transmission"; openFirewall = true; openRPCPort = true; }; };
I wonder if it matters that I am running a VPN.

In any case, my configuration file can be found here:


Based on your configuration it looks like the firewall is blocking the port. I was able to get it working after setting transmission to use a fixed port, opening it in the firewall and configuring port forwarding in my router (it took several minutes to start downloading).

If you’re going to use the GUI interface, maybe remove the service first, or at least while you’re getting it working.

Thanks for your reply.

I did a couple of changes but don’t really know what to do about my router. Mullvad VPN does no longer support port forwarding and I’m using networks that I do not have access to.

I wonder if there’s a way of making Transmission work without access to VPN or router port forwarding. My hope is that, given that it was possible in Debian (I ran Transmission without having to port forward), I hope that it’s possible here.

In any case, here’s what has changed:

When reading the changes, please keep in mind that the transmission service was toggled on an off in between changes. I did that because if I turned the service off, the app would quit whenever I did a peer port connection test. Am I doing something wrong in regards to enabling and disabling the Transmission service?

I have transmission-gtk installed.

I’m NOT running the NixOS transmission service (not sure whether I had a reason not to once, or just didn’t know about it until now).

I have port 57766 open in my firewall, although that might not be relevant.

I’m using Mullvad too. I used to have ports open on their servers, but I don’t any more since it’s no longer an option.

Transmission seems to be working for me. Fingers crossed.

So I guess try removing the part of your config that describes the transmission service?

I was using Qt and changed to GTK. Then, in the configuration.nix, I commented everything related to the Transmission service (effectively disabling it), and it worked!

When I run the Listening Port test for incoming connections, I still get a “Port closed” message, but at least I can now download and upload files!


1 Like