How to make home.packages show in gnome search?

SOLVED (comment)

Hey, so in my home manager config I have:

home.packages = with pkgs; [

I open gnome search bar with “super” key. And while typing vscode finds the application, typing “spotify” doesn’t. I still can launch spotify from terminal.

What influences that? Is it fault of the spotify package link. From source it looks like it indeed installs some desktop options, which should get recognized by gnome. Or is it controlled by some home-manager option?

Its just a matter of turning pc on/off. I guess gnome needs to relauch reload these desktop configs

This is Gnome Activities icons should appear on app install · Issue #12757 · NixOS/nixpkgs · GitHub. Someone will need to create a GLib patch, ideally a one that is upstreamable.

1 Like