How to not include nano?

Coming here from Artix Linux I noticed that NixOS can be somehow bloated and I want to change that.

OF course I want to start with not including nano, after I have already included nvim. Does anyone know how to do that?
I know about (this)[nixos/nano: add enable, package option, do not create /etc/nanorc by … by SuperSandro2000 · Pull Request #244324 · NixOS/nixpkgs · GitHub], but it doesn’t help me honestly.

BTW, wouldn’t it be better to use plain old vi instead of nano?

1 Like

The pull request you mentioned is already in NixOS 23.11, according to the changelog. So try programs.nano.enable = false in your configuration.nix.