How to setup NUR with home-manager and flakes

Hi All.

Im trying to work out how to setup NUR so I can install packages from it. Specifically with home-manager setup via flakes.

I have added it as an input to my flake.nix (flake.nix · d95b450dbd131da1537befb53516aee602ddec0f · Haseeb Majid / dotfiles · GitLab)

  inputs = {
    nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
    nur.url = "github:nix-community/NUR";

Where my home manager setup looks like (flake.nix · d95b450dbd131da1537befb53516aee602ddec0f · Haseeb Majid / dotfiles · GitLab):

      mkHome = modules: pkgs: home-manager.lib.homeManagerConfiguration {
        inherit modules pkgs;
        extraSpecialArgs = { inherit inputs outputs; };
   // ...
    homeConfigurations = {
      # Laptops
      "haseeb@framework" = mkHome [ ./home/haseeb/framework.nix ] nixpkgs.legacyPackages."x86_64-linux";

I tried to set nur overlays and then finally I tried to install some rofi packages (home/haseeb/features/desktops/hyprland/rofi.nix · d95b450dbd131da1537befb53516aee602ddec0f · Haseeb Majid / dotfiles · GitLab):

  nixpkgs.overlays = [

  home.packages = with pkgs; [

But when I run home-manager switch --flake ~/dotfiles#haseeb@framework.
I’ve tried numerous different iterations and get the same error:

       … while calling the 'derivationStrict' builtin

         at //builtin/derivation.nix:9:12: (source not available)

       … while evaluating derivation 'home-manager-generation'
         whose name attribute is located at /nix/store/85jb4qwmnjgc09imq5ia8qavklwc3mgb-source/pkgs/stdenv/generic/make-derivation.nix:303:7

       … while evaluating attribute 'buildCommand' of derivation 'home-manager-generation'

         at /nix/store/85jb4qwmnjgc09imq5ia8qavklwc3mgb-source/pkgs/build-support/trivial-builders/default.nix:87:14:

           86|       enableParallelBuilding = true;
           87|       inherit buildCommand name;
             |              ^
           88|       passAsFile = [ "buildCommand" ]

       (stack trace truncated; use '--show-trace' to show the full trace)

       error: attribute 'lib' missing

       at /nix/store/ih5mbzgcmymnz9mfw77qp73w2qw9z69d-source/pkgs/misc/rofi-wifi-menu/default.nix:42:15:

           42|   meta = with stdenv.lib; {
             |               ^
           43|     description = "A rofi wifi control panel";

I’m pretty new to nix and dont understand where I’m going wrong ? It works if I use it with nixos configuration following this guide; GitHub - nix-community/NUR: Nix User Repository: User contributed nix packages [maintainer=@Mic92].

However I think this belongs in the home manager config. Thanks.

This ended up issue with the pkgs being very old (updated 5 years ago)