How to stop GDM auto-suspend?

I set up a new NixOS machine to be my home server. It has Gnome, but that’s not its primary purpose.

The problem is that the “gdm” user is triggering suspend due to inactivity when it’s just sat there at the login screen.

I’ve changed the power settings on my user profile, but that only works when I’m logged in, I think. I’ve searched the configuration.nix documentation for a likely setting, but if there’s one there I’ve not found it.

How can I fix this without uninstalling Gnome?

Thanks

1 Like

try

  services.xserver.displayManager.gdm.autoSuspend = false;
3 Likes

Thanks, looks like I just need to figure out how to search this stuff effectively. :rofl:

Hopefully that solves the problem.

1 Like