How to turn off gnome hover click on kde plasma (and why did it get activated in the first place)

Since Thursday 2023-12-07 my laptop/tablet (a shiftbook/shift13mi) with nixos and kde plasma shows hover click behavior (i.e., whenever I hover my cursor over something clickable like a button or a link a timer is going down and then it clicks the thing). I did not consciously activate it and it is VERY annoying. After a reboot it was still there but I saw the following window attached to this post.

Searching for it so far has brought me the insight that KDE Plasma should not even have hover click, only gnome has that. Looking it up, the window I have closely reminds me of the options for gnome - but after all I never had gnome installed for my nixos setup.

On the left/in the background you can see this website:
On the right/front you can see the window that pops up.

I tried going back to an older build, one that was before the channel update to 23.11, but that did not help.

Any idea what is going on and how to fix it?

About my system:

Operating System: NixOS 23.11
KDE Plasma Version: 5.27.9
KDE Frameworks Version: 5.112.0
Qt Version: 5.15.11
Kernel Version: 6.1.64 (64-bit)
Graphics Platform: X11
Processors: 8 × 11th Gen Intel® Core™ i5-1135G7 @ 2.40GHz
Memory: 31,1 GiB of RAM
Graphics Processor: Mesa Intel® Xe Graphics

See also my lemmy post on that:

I would like to point out that this actually makes my install almost unusable, which was again an unexpected problem with nixos (another was links not being clickable in some apps like logseq).

That is not GNOME feature – GNOME has it built into the compositor so it cannot be used outside of GNOME.

It looks like it might be mousetweaks according to kde plasma - How to disable mouse click when hover on Manjaro - Stack Overflow

This would make sense. I indeed have onboard installed. How would I do mousetweaks --shutdown though? (How To Quit The Functions)
mousetweak is not found - And correct me but using it in the ephemeral shell would not do anything permanent, would it?

[sebastian@nixos:~]$ mousetweaks  --help
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "",
        LC_ALL = (unset),
        LC_ADDRESS = "de_DE.UTF-8",
        LC_NAME = "de_DE.UTF-8",
        LC_MONETARY = "en_DE.UTF-8",
        LC_PAPER = "de_DE.UTF-8",
        LC_IDENTIFICATION = "de_DE.UTF-8",
        LC_TELEPHONE = "de_DE.UTF-8",
        LC_MEASUREMENT = "de_DE.UTF-8",
        LC_TIME = "de_DE.UTF-8",
        LC_NUMERIC = "de_DE.UTF-8",
        LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("en_US.UTF-8").
The program 'mousetweaks' is not in your PATH. You can make it available in an
ephemeral shell by typing:
  nix-shell -p mousetweaks

Calling nix-shell an ephemeral shell refers to the fact that the requested programs will only be “installed” (really, available on PATH) within, it will not install them into any of profiles. (It just runs a subshell with the requested programs’ bindirs added to PATH.)

The subshell is not isolated from your system, though, so the programs can access your home directory and persist their configuration in ~/.config directory, for example.

(You can pass --pure flag to nix-shell and then it will clear out most environment variables but it should still run in the same namespace as an impure shell and the programs will have access to the root file system and your home directory. If you want better isolation, you would need some kind of containerization or virtualization.)

But in your case, I would just check the onboard settings and disable mouse tweaks there. I do not think the hover click feature was ever enabled out of the box when I used onboard in the past so I expect you must have enabled it accidentally in the UI.

While just grabbing with some groceries I had the same thought as well and looked again. And indeed theirs that setting.
I just excluded the possibility of onboard being responsible for that do too it still happening when onboard was deactivated - but I guess onboard activates mousetweak and does not be activated when it is shut down?
I think I will look into onboard and see whether that’s expected behavior, but my problem is solved with this. Thank you.

And for those who encounter the same problem: it is not actually in the onboard settings ( at least I did not find it there) but here: