How to use windows adobe reader via wine on nixos?

i switched from arch linux to nixos less than 3 months ago and i recently tried to use adobe reader, on arch it worked perfectly without problems but on nixos i can’t even get it to install. is my problem nixos related or there is a regression on wine?

1 Like

Notes from WineHQ - Adobe Reader DC

I’m just using regular Wine 7.0 release. The extra libraries are installed with the command winetricks mspatcha riched20 msftedit. Missing text in the UI is fixed by installing Segoe UI font. And that’s everything needed.

Right now the signature tool still doesn’t work. It seems to be using Chromium Embedded Framework (CEF) (as do other online features like log in) and CEF seems to be generally problematic in Wine (e.g. bug 44985).

What errors are you seeing in detail, how did you create your wine prefix, how did you install wine/tricks?

NixOS doesn’t make wine any harder to use IME, and it shouldn’t in theory. The wine build and version will probably differ subtly from arch’s, though, so there’s a small chance that causes issues.

Much more likely you just didn’t create the prefix correctly, though, given how hard wine can be to get right.