Hyprland starter pack

Hello, I would like to receive assistance with setting up Hyprland. Currently, I have only installed the window manager itself, and I have disabled lightdm since it doesn’t work on Wayland. Even waybar is not installed. There is practically no content in the configuration file except for the launch command; the configuration itself is absent. When I launch Hyprland, I only see the wallpaper and cursor, but I’m unable to move the cursor or interact with anything. What steps do I need to take for basic usage? Specifically, how do I install and configure waybar, hyprland basic config, and how do I choose a login manager?

1 Like

If you are using home-manager, there (in the unstable branch at least) are home-manager modules for configuring waybar (see here for options) and for configuring Hyprland (see here for options).

I personally do not use a display manager, but some options which work on Wayland include GDM, SDDM, and greetd. You can search for their configuration options here.

If you are not using home-manager, you can install waybar using programs.waybar.enable = true and then configure Hyprland and waybar following their wikis as on any other distribution.


I understood about waybar, but what if when I log into Hyprland with tty I can’t even move the cursor, the cursor is in the center of the screen and that’s it.

Have you seen this wayland bug: monitor "highres" can't work after update to v0.29 · Issue #3103 · hyprwm/Hyprland · GitHub

I got hit by it just the other day…

It’s not my case, i have not any configuration of my Hyprland, only this:


Did you set programs.hyprland.enable = true in your configuration.nix? Per the Hyprland wiki,

The NixOS module enables critical components needed to run Hyprland properly, such as: polkit, xdg-desktop-portal-hyprland, graphics drivers, fonts, dconf, xwayland, and adding a proper Desktop Entry to your Display Manager.

But I’m using home-manager with flakes, how to to that with hm?

In your /etc/nixos/configuration.nix (or in the nixOSConfigurations section of your flake), you can set the NixOS option programs.hyprland.enable = true. As for moving the cursor, you should at least configure inputs (which you can do using the home-manager module).

Well imagine that I have already added this to the section, everything else is normal?


I added the inputs, didn’t I?

I meant configuring input devices in your hyprland configuration, not inputs to the flake. My apologies for the confusion.

Thanks for help.

I would also be glad if you could show me what it looks like or at least where to find the available options for this.

P.S I found that itself

Have you read the Hyprland wiki on how to actually configure Hyprland with the home-manager module as you’ve enabled? Hyprland on Home Manager | Hyprland Wiki

All the other configuration options are listed in the wiki too.

No idea why your mouse cursor isn’t working, I’d guess it’s going to be something like you’re missing libinput or such. I’d suggest also enabling the NixOS module, so that it can install all the various other services you need - this used to be recommended, but looks to have disappeared with the wiki refactor: Hyprland on Nix Os | Hyprland Wiki

If it still does not work after this, please share your logs.

While I’m at it, how do you install these things? This should not work, absolute paths are not allowed:

nixosConfigurations."Snow-Flake" = nixpkgs.lib.nixosSystem {
      system = "x86_64-linux";
      specialArgs = { inherit inputs; };
      modules = 

If you’d like you can have a look through my configs and take what you like:

Really not a whole log going on for Hyprland specifically, but I also have a more generic wayland module that sets up waybar and wofi, and a few other things:

1 Like

Of course, I have read it, and my code does not contain errors, except for the forced insertion of absolute paths. Since I do not know how to add non-absolute paths if the files are in another location, it doesn’t matter, as I can add “–impure”.

There’s an official Hyprland flake which contains a home-manager module. You might want to use that instead since its what upstream uspports. (And what I use myself).

The official wiki: Hyprland on Home Manager | Hyprland Wiki

EDIT: Sorry, I’ve not noticed @TLATER response before commenting.

Currently, both the HM module inside the flake, as well as the upstream HM module are supported. The one in the flake will be superseded by a more thorough module which allows configuring options in the style of freeform modules, which will be typechecked by a DOM.
Until then, feel free to use one of the two available modules.

@TLATER using the NixOS option is still recommended in Nix | Hyprland Wiki.


Ah, bit of bikeshedding then, that note should absolutely also be on the home-manager specific page, I didn’t even think to click the overall nix page before looking at the home-manager details.

I suppose that’s for upstream discussion though, not here :wink:

Thanks for the feedback, I’ll add that note both to the HM and the NixOS pages.