I dont understand this error :c

Hello! I just changed the color theme and when I did a nixos-rebuild this error appears. What could it be?

Presuming that config/scripts is a file/directory in your flake (and that youre using flakes to begin with), make sure to git add that directory before invoking nix


I did “git add” on the directory, then I did nixos-rebuild and the same error still occurs

Hmm. Are you sure you added the “No such file or directory”? What does git status say?

I think you maybe meant git add . which adds all files to staging. You also don’t have to stage the files if you are experimenting. My favorite git trick I have learned working with flakes is to mark all files as intent-to-add, which does not stage the files, but lets you move past this error. You can do that with -N, so git add -N . marks any new files as intent-to-add recursively from the current directory.

You also have to be careful to make sure you are at the top level of the git directory. If you do it in a subdirectory, it only recurses on current dir down, not up.

I would also give trying to add --show-trace to what your build command is.

Also (last thing! :wink: ), could you post the plain text in the future instead? 1. it hurts my eyes 2. makes it more searchable and usable to other users in the future. No one else can learn from this question as it is now.

1 Like

I’m sure this is the solution, anyway I already reinstalled the system, I’m recently using this Nix configuration so that solved it! Regarding the plain text, I will keep that in mind!