IBUS hugs the corner with a broken theme

I’m trying to make use of ibus on NixOS the same way I had it on Fedora. On Fedora it was styled to fit in with the GNOME desktop as you would expect, but over on NixOS with the same desktop it has this pure white theme and is stuck to the top left of my main monitor?

Here’s my config for ibus. Any help please? I’ve also attached a picture of what it looks like right now

 i18n.inputMethod.enabled = "ibus";
 i18n.inputMethod.ibus.engines = with pkgs.ibus-engines; [

Solved it! Well, not really. I instead switched to fcitx5 and added gnomeExtensions.kimpanel as well, which integrates it better with the Gnome desktop including visuals. I also made sure to disable the default switch keyboard layout keybinding because it interrupts it

Here’s the fcitx5 code:

i18n.inputMethod = {
  enabled = "fcitx5";
  fcitx5.addons = with pkgs; [

1 Like