Impossibly slow qutebrowser, chromium

Good evening.

I was heartbroken today to find my installation entirely messed up. There were disk errors that I fixed with fsck from a thumb drive boot.

This was all after an update and a channel switch. I can go back to my old channel’s version, but then I lose some of the crucial stuff that I needed to update for.

at first it just hung on startup. a few minutes of small white cursor on a black screen.

now opening any windows besides the terminal and it just hangs for a really long time. qutebrowser won’t load. chromium takes forever to render two windows, but once its up I can seem to run it a bit, but I’m not getting too adventurous.

configuration.nix: http://ix.io/3ExH

cat /proc/version: Linux version 5.15.0 (nixbld@localhost) (gcc (GCC) 10.3.0, GNU ld (GNU Binutils) 2.35.1) #1-NixOS SMP Sun Oct 31 20:53:10 UTC 2021

cat /proc/cpuinfo: http://ix.io/3ExJ

It’s a Thinkpad T495.

any other info I can provide? any leads?

I swear I must have fixed 5 different issues today. what a rollercoaster. can’t wait to get this thing back to its former glory (but with updates)

It sounds like your disk is failing, did you run a SMART test?
Programs crashing or hanging could be due to corruption in the Nix store, try running nix-store --verify --check-contents --repair.

1 Like

I don’t think the disk is failing (knock on wood) because if I go back to the old build, everything is fast again. I just can’t use a bunch of software I need.

I’ll boot back into the slow new build and give that a go. thanks!

Uhm, the disk being fine and rolling back restoring the system suggests the update was interrupted abruptly, maybe due to a power failure?

I don’t think there was an interruption to an update. rebooting presently! I’ll keep you informed. Thanks much!

1 Like

No need to reboot into slow generation, the store is the same between fast and slow generations. You should be able to run the command with the same effect from the fast generations.

I had something similar (along with others) a while ago, does

  boot.kernelParams = [
    # NECESSARY !! https://discourse.nixos.org/t/browsers-unbearably-slow-after-update/9414/30
     "intel_pstate=active"
  ];

help ? (reboot)

the nix store is in fine fettle, and the disk passed the s.m.a.r.t test.

this computer is AMD, but I’ll try anything at this point…

and ofc, it didn’t work. I expected that, but it was still disappointing haha.

hahaha now I’m getting a missing mscvr module trying to switch back with a new build. booting back into an old build, ::mario voice:: here we gooooooooo!

okay, was able to not only update back to the old config, but also add pip back in, just in case that was an issue. at any rate, things are still slow on my newest build. this feels like total chaos.

Can you give us the output of nixos-version --revision for both the last good and first bad generation?

I fixed it! I turned off the latest_kernel tag and now I’m good! ugh so frustrating but I learned a lot!

1 Like

Can someone explain why using the latest kernel was making everything slow?

I think it might be a kernel bug. It was introduced in cpufreq: intel_pstate: Use passive mode by default without HWP · torvalds/linux@33aa46f · GitHub, which says the passive mode should be on par or better but for me, it lowers the frequency to 800 MHz.

1 Like
Hosted by Flying Circus.