Install NixOS on laptop: I'm failing hard

I installed NixOS unstable on an Acer Swift 3. I installed gnome3 by enabling the desktopmanager.

Any pointers for any of the following?

  • I can’t start gnome-terminal, it fails to start gnome-terminal-server somehow. I’m basically running nixpkgs/gnome3.nix at e233a9d4dd1484d2b79e496d45f5e785642638ef · NixOS/nixpkgs · GitHub with the same nixos config except that my home dir is shared with an Ubuntu install.
    • when I run the server manually with dbus-launch /nix/store/..../gnome-terminal-server, it complains about the locale until I set LC_ALL=en_us.UTF-8. Even then, I can’t start gnome-terminal, it just times out
  • Epiphany can’t use opengl, I have to start it with WEBKIT_DISABLE_COMPOSITING_MODE=1. I can’t find any errors related to it. This happens in X and Wayland both.
  • I’d like to share the flatpack install between Ubuntu and NixOS, any ideas on how to achieve that?

Thanks :slight_smile:

1 Like

I “solved” the gnome terminal issue by adding LC_ALL=en_us.UTF-8 in my .pam_environment, but I wonder why it didn’t just work?

The epiphany might be an older epiphany bug, perhaps we have old gnome3 binaries? The only errors it prints are

Cannot get default EGL display: EGL_BAD_PARAMETER
WaylandCompositorDisplay initialization: failed to connect to the Wayland display: webkitgtk-wayland-compositor-83877feb-0535-4608-998b-92276c53121c

but it does that with or without the compositing mode environment variable.

I shared flatpak by symlinking /var/lib/flatpak, that was easy at least :slight_smile:

1 Like

I’ve seen this too. It sounds like this bug:

But note the “fix” is to just disable AC :slight_smile:

1 Like

In other words, disable hardware acceleration? YouTube is unusable. Is there no other workaround? should address this