Install NixOS via USB stick does not recognize hard drive

I am trying to install nixos with the USB stick on a notebook. I have a 500 GB SSD in the computer. On the first partition is a Windows 10 and on the second partition I wanted to install NIXOS. Unfortunately, the NIXOS installer does not recognize the hard drive or partition. It shows only the stick on /dev/sda. Others like /dev/sdb or so I have not found.

cat /proc/partitions does not give me more information.

This is what the partition looks like under Windows 10:

And this is what the NIXOS installer shows me:

What am I doing wrong, does anyone have a tip for me?

Usually SSDs are under /dev/nvme0n1, /dev/nvme1n1 (and partitions are /dev/nvme0n1p1, etc.)

Thank you, but I can’t find anything under /dev/ that starts with nvme. The disk itself is named in Windows Device Manager :


so it is the following harddisk:
Toshiba XG6 KXG60ZNV512G 512 GB NVMe M.2

Is there anything for me to consider?

I haven’t heard of a driver issue with SSDs on Linux, but possibly that could be it.

Another thing that might be causing it is the SSD being in some special Intel RAID mode (you’d have to check in bios for that), I forgot how it was called. It’s a setting in bios with a value of “raid” if it’s enabled.

Not SSD in general, only nvme.

Anyway, I’ve heard problems with nvme not getting recognized under Linux when some settings in the firmware are off.

Thank you very much. I actually had “Raid On” enabled in the SATA operations. I have now set off “AHCI” and it seems to recognize the hard drive with the NIXOS installer. Means only unfortunately that my Windows 10 no longer starts and I have to reinstall that too. But is not quite so bad, because the Windows I had also just reinstalled on it.


Although quite offtopic here: you don’t have to. Configure it to boot to safe mode, then shut down. Switch back after making the change.

If that doesn’t help: Google. You’ll need to make sure it loads the AHCI driver instead of whatever RAID driver it’s now using - then it’ll boot.

When I disabled Intel VMD, nvme was detected.