Installing GNU Emacs does not put info files in the correct place

This is my first time running NixOS, so I’m still learning the Nix “way”.

I ran nix-env -i emacs to install GNU Emacs, which worked fine, but then when I try C-h i (control-h i) to get the info (which also works just fine), the GNU Emacs info manuals are not listed. So I have to use C-u C-h i and then specify the full path (/nix/store/rdvijcyyszs9axlr76xvfbyxa6qq32mr-emacs-26.3/share/info/ in this case) just to be able to read the GNU Emacs info page. Did I miss a step to install GNU Emacs correctly and have the info pages hooked into the info system? Running info from the command line or even from inside GNU Emacs seems to pull files from the /run/current-system/sw/share/info directory.

Thanks for any help or guidance (pointers to doc are gratefully appreciated).


1 Like

Unfortunately it is not entirely trivial, the Home Manager module describes it quite well. If you use HM then it should be sufficient to have = true in your configuration.


Thanks @rycee!!

Pardon the confused look but… Home Manager? Maybe I missed seeing that in the manual?

D’oh!! there was a link there I missed to a github page… reading…

thanks again!!

Just came across this thread because my info manual for haskell-mode was missing. Thanks for pointing the option out. In my opinion, it should be advertized more aggressively. Actually, I think it should be set to true when emacs is installed.