Installing Toshiba eStudio 330AC printer driver

Hi Everyone,

After saying Thank you for the support on my previous topic, I now have an issue that I am hoping won’t be an issue.

I have the Toshiba eStudio 330AC multifunction network printer, which for some reason or rather won’t play ball on Nix using CUPS (it worked straight away on other Distros)

Can you advise on the most recommended printer & Scanner application, and how to get the printer to work please.

Thank you in advance

Oof, printers. What have you tried so far? I assume you’ve seen the services.printing module?

See also this thread for a brother prnter, that may or may not work for yours: Brother DCP-572DW wrapper - #3 by peterhoeg

Ohhh. I just got thrown in the deep end.

The funny thing is that I downloaded the CUPS Toshiba printer plugin, and it shows that it does exist in the configuration.nix file.

However, going into CUPS via system settings or localhost:631, the Toshiba driver isn’t there…

Time for me to make a little contribution to this topic;

In the Software Center (or similar to where you download your applications), look for and download Print Settings (system-config-printer).

You may need to search for and download the PPD file, but this will stop your printer from gathering dust.

Happy printing everyone

1 Like