Issues Installing Foundry (nightly version) on NixOS

Hello NixOS Community,

I’m attempting to install the Foundry (nightly version) on my NixOS system by following the installation guide provided in the Foundry Book. However, I’m encountering a problem during the foundryup section where the tools (forge, cast, anvil, and chisel) seem not to be installed correctly. Below is the output I receive:

foundryup: installing foundry (version nightly, tag nightly)
foundryup: downloading latest forge, cast, anvil, and chisel
foundryup: downloading manpages
/home/reblixt/.foundry/bin/foundryup: line 273: /home/reblixt/.foundry/bin/forge: cannot execute: required file not found
foundryup: done!

The error messages indicate that executable files cannot be found or executed. I’ve checked, and the files seem to be downloaded but perhaps not correctly set up for execution.

System Information:

NixOS version: 23.11
Used configuration: My configuration.nix includes a relatively clean install with a few applications, Nvidia drivers, and i3 window manager. There are no extensive customizations beyond these.

What I’ve Tried:

I have checked the permissions of the downloaded files to ensure they are executable.
Attempted to manually execute the downloaded files with the same result.

Has anyone encountered this issue before, or does anyone have suggestions on what might be wrong? Specifically, are there any dependencies or NixOS-specific settings I should check?

Thank you in advance for your help!

Solved Update here.

I stumbled on a youtube video of “No Boilerplate” That hinted about running binarys
I then added in configuration.nix file

programs.nix-ld.enable = true;
programs.nix-ld.libraries = with pkgs; [   

Rebooted the PC,

Then tried again with “foundryup” and everything installed correctly!

I hope this “fix” good or bad comes handy for anyone els trying to install Foundry (Solidity framework)