Issues with brave and ghost monitor with basic nixos/hyprland install

I run nixos with a basic wayland/hyprland config. Just curious if anyone has come across these issues before. For the most part I have figured them out by going through the hyprland/nixos wikis, however two issues have stumped me. One issue is for the most part solved, while the other is still causing me issues.

First issue:

When I run hyprctrl monitors all, it lists a “ghost” monitor titled “Unknown-1” with currentFormat: Invalid. This was driving me crazy as I only have one monitor. I have temporarily solved this by disabling the monitor by adding monitor=Unknown-1,disabled to my hyprland config. But this is still so weird to me, anyone got any clues?

Second issue:

I use brave as my browser but am I facing some “glitching” issue that primarily happen when I type in its search bar. I did a couple of searches and it comes up that chromium based browsers do have some issues with wayland but none of the issues others have reported seem to be the one I’m facing now.

I have tried the following things:

  • changed the default brave command to brave --enable-features=UseOzonePlatform --ozone-platform=wayland

  • Set NIXOS_OZONE_WL="1" as an environment variable as documented here https://nixos.wiki/wiki/Wayland

  • explicitly set the chrome://flags/#ozone-platform-hint flag to wayland.

After all of this, my typing/glitching issue still persists. Does anyone have any insight into what might be happening? Is this just a regression with brave? For further context I quickly downloaded firefox which had no such issues. This would suck though as I would like to continue using brave.