Issues with USBC DP alt mode

Hey all,
I recently picket up a 2020 model Asus Zephyrus G14, with the Ryzen 9 CPU, and an RTX 3060 Max-q. This issue I am currently having is connecting the device to external monitor(s) with the USBC port on the left side of the laptop (Marked as DP). I configured Nvidia Optimus as I did on my other laptop, with a intel 11th gen and a 1650TI, and I have no issues when using the laptop, and getting things such as Hashcat, and games to run on the dGPU. The issues seems to be that the USBC DP is connected to the dGPU, and as apposed to the integrated, which the internal, and the HDMI port are, which means in order to get display output from the USBC port i need to remove the Nvidia prime lines form my config and reboot. Has anyone had this issue on other laptops, and if so how did you get around this? I was thinking about using Optimus-Switch but I want to keep it as seamless as possible, as I do “grab and go” with the laptop all the time.

Any help is appreciated!

shot in the dark here — but you may want to try autorandr. It listens for udev changes, including plugging/unplugging display devices, and then can run a script to change the display configurations based on the display hardware present. This assumes you’re running on X, but there may be an equivalent for Wayland.

I did a bit more tinkering last night, and it came down to the fact that there was not a x11 session running on the dGPU because it was in Nvidia offload mode, i switched to sync, which keeps the dGPU awake when not in use, and it did sole the issue with the displays not connecting.

I now have a new issue, every time I make a change at all to the display layouts, it hard crashes X11 and dumps me to the login screen. If I log in, it simply just crashes again instantly. The only was to get around it is to unplug the External display and log in again. The odd part is the monitors do work, they are just in the wrong layout. This even happens if i try to disable the internal display. Starting to think I should just stick with the HDMI and get an ultra-wide.