KDE doesn't render nerd-font glyphs

Good day. I’m on NixOS 23.05 and found a strange issue where KDE (QT?) based apps don’t display many nerd-font glyphs properly, e.g. those suggested in the starship manual. It’s only in KDE/QT apps, and only on NixOS (KDE Neon / Kubuntu work fine)

The font I use is “MesloLGSDS Newd Front Mono”

Chrome displays them just fine as you can se below (at least I do)


GTK-based app have no issues as well. Here is tilix terminal for example:

But KDE/QT based stuff struggles. Here is how I see it in the console

I looks like NixOS-specific issues because it all works just find in KDE-neon running in Virtualbox (KDE 5.27 on Wayland)

And even on my old laptop with Kubuntu 20.04 LTS it works just fine as well.

Not sure if it’s a bug or configuration problem?

All I do in confugration.nix is

services.xserver.displayManager.defaultSession = "plasmawayland";
services.xserver.desktopManager.plasma5.enable = true;

Same issue happens with kate as well as any QT app (Dolphin, klipper, etc.)

Opened a bug: KDE doesn’t render many of the nerd-font glyphs · Issue #244281 · NixOS/nixpkgs · GitHub

hum… in my case, using jetbrains mono nerd font and noto color emoji:


What do you have as font setting on the last tab of the “appearence section” ? ( should be something like disposition of complex text, but dont know the string for sure because I have it on another language, not english )

1 Like

Wow! Somehow I completely missed that settings tab.

The emoji font there was set to “-1” which looked dodgy :slight_smile:

After setting it to Noto Color Emoji, 11pt, it all renders just fine!

(still some weird artifact in the dialog UI :thinking: )

@aJWXSLWNVHRrz Thank you! Do you know how to make it work in other KDE apps? If I set system font to Noto Color Emoji it obviously work but that text itself looks way off.

Is that some kind of font-fallback mechanism that is not working?

1 Like

I’ve managed to get it working across KDE by applying font configuration as mentioned here: #86601 (comment).
Though I understand the concerns why it’s not the default, that was a hard one to dig out.


1 Like

Actually I didnt noticed other apps werent working :slight_smile:

Thanks for digging deeper and finding the solution !

Yeah, finally when somebody puts an icon in the email subject and gmail puts it in the browser’s window title I can see the icon in the task manager :slight_smile:

1 Like