KDE Plasma Application Launcher and other random UI elements extremely delayed in response

Last Tuesday I noticed that some electron apps generated crackling audio, so I made adjustments to the sound settings and did a rebuild with those settings. I only logged on one other time after that, at which point, I decided it was time to do a nixos-rebuild switch --upgrade like I do on occasions. No, I don’t have the habit of backing up configurations, but I will once I resolve this.

Anyway, we had an abrupt situation in which we had to rehome a dog and we were busy with that until last night, when things finally calmed down and I was able to use my computer again.

I’ve now found that everything is much, much slower on NixOS than it was last week. The single most obvious symptom right now is the Application Launcher. I click on it and it takes up to 4 seconds to show up. I also noticed that the entire “Help” category of it is empty, along with “Favorites”.

Another noteworthy thing is that chrome based browsers are affected. Firefox seems unaffected. FF is my default, so it’s fine, but the Chrome detail may help diagnose.

Created a new user and logged on as that. No better.

I’ve since tried reverting my audio settings, along with all sorts of other reversions. Nothing seems to work.

The one thing I can do is load up the last generation from last Tuesday. Everything feels great in that generation. But I’m stuck and can’t add packages or anything. As soon as I rebuild, it churns to a halt again.

I’m suspecting the hardware configuration was changed during the --upgrade, but I’m too new to know for sure.

Here’s the current configuration.nix

And here’s a log from a fresh boot.

I’m really tempted to just back up configs and files and reinstall, but I’m a bit sick of solving everything in Linux with that. I’d like to learn to fix this stuff.

Any help is appreciated. Thanks.

Do you know which version of nixpkgs you are using? Should be able to find out by running nix-channel as root. If it is nixpkgs-unstable, it might be worth switching to a release version, since in my experience, stuff breaks very regularly on unstable

sudo of nix-channel --list gives me this
nixos https://nixos.org/channels/nixos-23.05

nothing under non-root user

Cool, in that case, maybe check the diff over the past few weeks for the nixpkgs-23.05 branch of nixpkgs, just to make sure nothing suspicious happened.

If that doesn’t turn up anything, I would VC your config (including the hardware config) and start experimenting! That is the real power of nix: it is hard to irreversibility break your system!

Ok, so you’re thinking it was probably a change to one of the system packages that I have (since user swap did nothing)? I’ll probably still compare the diffs and all, but it’ll be a lot less stressful if there isn’t this nagging feeling that it’s something that I did and have to resolve.

My guess is that something changed in nixpkgs. I am pretty sure nixos-rebuild doesn’t change any of your configuration files.

Turns out it was the nividia packages that updated and broke it. I must have failed to restart when I first tried unloading those.

Anyway, I had the option to either turn off the compositor or use hardware.nvidia.forceFullCompositionPipeline = true;.

I went with the latter, but had to apply it to both monitors with a startup script.

systemd.user.services.nvidia-settings = {
    enable = true;
    serviceConfig = {
      ExecStart = "${pkgs.writeScript "nvidia-settings.sh" ''
        nvidia-settings --assign CurrentMetaMode="DP-0: 2560_1440_100 +0+0 { ForceFullCompositionPipeline = On }, DP-2: 2560_1440_100 +25>
      Restart = "always";
      RestartSec = "5s";

Adjust for resolution and refresh rate
Hope this helps someone else someday