KDE widgets look off on a freshly installed NixOS

Hello. Parts of KDE theme looks off in a freshly installed NixOS:

The widgets in the window on the left-hand side looks fine, but the widgets in the window (System Settings) on the right-hand side look very off.

I would appreciate any help here.

Hello and welcome!

This is a bug that affects stable 20.09, I assume this is what you are running? It is fixed in the upcoming NixOS release:



Hmm. I did suspect that some QML components weren’t reading the theme right. Thank you for the pointer. I will wait for the end-of-may? Nixos release.

In general, which of GNOME or KDE has proven more stable on NixOS? I don’t mind using either of the DEs.

Recently, GNOME has been the default in the installation image and is presumably therefore the most stable. Until um I think about a year ago it was KDE.

Thank you. Well I will stick with KDE for now. Want to focus on learning Nix-isms first.

1 Like

I’ve been using KDE exclusively since switching to NixOS and while there are a number of papercuts, it makes for a
perfectly functional daily driver.


You can probably fix it on 20.09 if you want.

  1. ensure qqc2-desktop-style is in environment.systemPackages.
  2. QT_QUICK_CONTROLS_STYLE either needs to be unset or set to org.kde.desktop (the Plasma bit in the linked issue is incorrect.

If qqc2-desktop-style is already in your global env, you don’t need to rebuild - just fiddle with the variable in a terminal and launch systemsettings5 from there.

1 Like

I moved to nixos-unstable. Works quite well for a desktop, and I dont have to worry about sharing home.nix between nixos and macos.

Now I’m wondering whether I can make KDE configuration declarative. By default, baloo is configured to also index file content, bringing the system to a crawl.

I almost gave up on nixos-unstable before I recalled this problem from past experience.

PS: thank you for your effort!

how to declarative configure nixos to stop indexing by baloo?

1 Like

how to declarative configure nixos to stop indexing by baloo?

We don’t have that option. There’s some talk in home-manager about adding it there.

I know there’s a lot of hatred towards baloo, but I’ve using it every day for a long time - works great for me.

thanks for the info
*it works (always) fine after the installation but at a certain action the whole system get unusable because of baloo (but it is very hard to make that reproducible …)

I meant to say that this is a KDE default.

Baloo works like a charm for me as long as it indexes only filenames, and not the content.

Baloo and Present Windows are indispensable to me.