Kexec hangs on install

Hi,
I would like to install NixOS using nixos-anywhere on a mini pc with an Intel N5100.

I have tried to install starting from Fedora 39 and NixOS (via iso), using from a another machine:

nix run \
    github:nix-community/nixos-anywhere \
    -- \
    --flake .#htpc \
    --print-build-logs \
    --debug \
    user@ip

But just after the lines:

+ kexecSyscallFlags=--kexec-syscall-auto
+ /root/kexec/kexec --load /root/kexec/bzImage --kexec-syscall-auto --initrd=/root/kexec/initrd --no-checks --command-line 'init=/nix/store/fpwr9bsdi8ddizn0j9ijhy1gp7yak3m7-nixos-system-nixos-24.05pre-git/init console=tty0 console=ttyS0,115200 loglevel=4'
+ echo 'machine will boot into nixos in 6s...'
machine will boot into nixos in 6s...
+ test -e /dev/kmsg
+ exec

The screen goes black, the minipc is still powered on but nothing happens.

I can replicate the hangs by running:

curl -L https://github.com/nix-community/nixos-images/releases/download/nixos-23.11/nixos-kexec-installer-noninteractive-x86_64-linux.tar.gz | sudo tar -C /root -xvzf-
/root/kexec/run

If I run dmesg during the 6 sec I get:

[   75.819535] + cleanup
[   75.819573] + rm -rf /root/kexec/kexec/tmp.i3NzDovf9i
[   75.819591] + nohup sh -c 'sleep 6 && '\''/root/kexec/kexec/kexec'\'' -e'
[   75.825248] shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
  • 23.11: error
curl \
    --location \
    https://github.com/nix-community/nixos-images/releases/download/nixos-23.11/nixos-kexec-installer-noninteractive-x86_64-linux.tar.gz |
    sudo tar -C /root -xvzf-
/root/kexec/run
  • 23.05: error
curl \
    --location \
    https://github.com/nix-community/nixos-images/releases/download/nixos-23.05/nixos-kexec-installer-noninteractive-x86_64-linux.tar.gz |
    sudo tar -C /root -xvzf-
/root/kexec/run
  • 22.11: kexec correctly
curl \
    --location \
    https://github.com/nix-community/nixos-images/releases/download/nixos-22.11/nixos-kexec-installer-noninteractive-x86_64-linux.tar.gz |
    sudo tar -C /root -xvzf-
/root/kexec/run

Any suggestions?

Thanks