Keyboard requires keypress to turn on/detect

Hi everyone,

I have a KeyChron K2, which I usually connect to my desktop with the usb port on the back or a hub. The problem is that, at the systemd-boot menu and again on my login manager, I need to press a key on the keyboard before I can start typing. It isn’t a major issue now, since I have set up tpm2, but when typing passwords without echo, it misses the first character without me realising. This only happens once during the boot menu and once at the login (i.e. phase 1 and 2). The keyboard works normally the rest of the time. I also have the kernel option usbcore.autosuspend set to -1. Can someone suggest me a solution this?