Keycloak module in development mode?

Hey there, I get an error because I have no certs set for keycloak:

Failed to start server in (production) mode
Feb 16 08:06:20 nixos keycloak-start[953]: 2024-02-16 08:06:20,837 ERROR [org.keycloak.quarkus.runtime.cli.ExecutionExceptionHandler] (main) ERROR: Key material not provided to setup HTTPS. Please configure your keys/certificates or start the server in development mode.

Obviously, the error message is pretty clear. I have to start keycloak in development mode, and that is possible with something like start-dev, as I read in the keycloak documentation.

The only problem is that I would like to have this set declaratively in my below nixos configuraton, so that it automatically starts in development and thus does not fail to run. There is no need for https in this test environment.

Here is my current config:

services.keycloak = {
    enable = true;
    database.passwordFile = toString(pkgs.writeText "password" "keycloak");
    settings = {
      http-port = 4000;
      hostname = "keycloak.local";

Does anyone have an idea how I could set that there? I probably have to somehow modiffy the systemd service that executes the keycloak command to use the dev mode.

I just checked the keycloak module in nixpkgs, and I found the part where start-dev would be needed instead of just start:

Any way to keep everything as is currently in that module and only modify / overwrite that single line?