Live CD/USB not booting

I am trying to make a live USB to install NixOS, but it isn’t working. I’ve tired two drives, two versions (19.09 and 18.09, both match checksums), several installing/flashing/burning methods, several booting methods, but no luck (despite drives working fine with archiso).

I tried making the live USBs with dd if=nixos.iso of=/dev/sd?, verifying the device with lsblk, with and without bs=4M, with partitioned and unpartitioned drives, and using Rufus and Etcher on a Binbows box. All had same result.

I tried booting from the firmware boot menu, creating a custom boot optipn in firmware (pointing to an efi, /EFI/boot/bootx64.efi iirc), chainloading from GRUB2 (on the machine), loading bzImage and initrd through the machine’s GRUB, and through GRUB’s iso booting. All had the same result.

Upon booting to the drive, the drive’s activity LED blinks, the screen displays black with a white underscore in the top left, the drives stops reading, and nothing else.

Both drives function when turned into Archlinux live USBs just fine using dd method and booting thru firmware boot menu.

Hardware is a Dell XPS 15 9570 and a Lexar 32GB USB 2 drive and Microcenter 16GB USB 2 drive. I can add extra information if needed.

What am I missing here?

(orginally a Reddit post but received no feedback within a day. this issue has gone on for days and i would like a solution because nixos looks really cool)

Perhaps an even newer image, such as https://hydra.nixos.org/build/107715763/download/1/nixos-minimal-new-kernel-20.03pre203904.bb1013511e1-x86_64-linux.iso , might work?

That image did work. Thank you!

1 Like