Lutris games and minecraft unplayable on hyprland, but runs fine on gnome

like the title, games on lutris and minecraft are unplayable on hyprland, but for some reason, it works fine with gnome. I did not use gnome on Xorg session so i think it’s safe to assume that it’s gnome on wayland.

Lutris just outright exits the game.

related lutris log (on hyprland):

Start monitoring process.
XIO:  fatal IO error 2 (No such file or directory) on X server ":1"
      after 296 requests (296 known processed) with 0 events remaining.
Monitored process exited.
Initial process has exited (return code: 0)
Exit with return code 0

minecraft runs at 15fps on hyprland but when i switch to gnome, it runs at a average of 120 ish fps

What i tried:

based on the log, i though it was problem with xserver, so i added xwayland option in hyprland, doesn’t help

    programs.hyprland = {
      enable = true;
      xwayland.enable = true;
      package = inputs.hyprland.packages.${pkgs.system}.hyprland;

i put the same thing in my home-manager module:

  wayland.windowManager.hyprland = {
    enable = true;
    systemd.enable = true;
    xwayland.enable = true;

i also enable opengl and dri support, but it remains the same

  hardware = { 
    opengl = {
      enable = true;
      driSupport = true;
      driSupport32Bit = true;

so i try adding xdg portal gtk, still did not help at all, same error

  xdg.portal = {
    enable = true;
    extraPortals = [