Managing nix-daemon via systemd in Ubuntu

I was looking at this wiki, not sure if the ExecStart in the file /etc/systemd/system/nix.service is correct,

ExecStart=/usr/local/bin/nix-daemon $EXTRA_OPTS

As the nix-daemon is not present under /usr/local/bin, I think it should be:

ExecStart=/nix/var/nix/profiles/default/bin/nix-daemon $EXTRA_OPTS

Can anyone please confirm? or if there is a better way of managing nix-daemon via systemd.

On digging further, it seems there is a service file present.

$ cat /etc/systemd/system/nix-daemon.service
Description=Nix Daemon

ExecStart=@/nix/store/6chjfy4j6hjwj5f8zcbbdg02i21x1qsi-nix-2.3.1/bin/nix-daemon nix-daemon --daemon


But, still the systemctl enable fails

$ sudo systemctl enable nix-daemon
The unit files have no installation config (WantedBy, RequiredBy, Also, Alias
settings in the [Install] section, and DefaultInstance for template units).
This means they are not meant to be enabled using systemctl.
Possible reasons for having this kind of units are:
1) A unit may be statically enabled by being symlinked from another unit's
   .wants/ or .requires/ directory.
2) A unit's purpose may be to act as a helper for some other unit which has
   a requirement dependency on it.
3) A unit may be started when needed via activation (socket, path, timer,
   D-Bus, udev, scripted systemctl call, ...).
4) In case of template units, the unit is meant to be enabled with some
   instance name specified.

Could you type systemctl cat nix-daemon.service instead. There seems to be something funky going on here