Mediatek 7961 wifi not working properly (Vivobook Pro 16x)

I have a Vivobook Pro 16x and I just installed Nixos on it. Everything works except the Wifi. The wifi works occasionally, but not always.

I updated the kernel to the latest version by setting boot.kernelPackages = pkgs.linuxPackages_latest;, as I read that was needed for the mediatek 7961 chip to work.

I’ve also tried setting networking.networkmanager.wifi.backend = "iwd", which seems to work slightly better, but only for a few seconds.

So my wifi works for a bit, few seconds, and then nothing loads.

Are there any other settings I can try out?


Looks like this is a known problem (, and the “solution” that seems to work is booting without the power cable attached…

I’m considering just getting a different laptop, it’s still within the grace period in which I can return it.

A few notes:

  1. Check dmesg in a broken/unbroken state. It can help properly figure out what the issue is. Colors can help a lot, so if you dump it to a file try to preserve them.
  2. Given the flakyness and charging-related failure, this sounds like some sort of power delivery failure. It’s possible the hardware is simply broken.
  3. There’s some mention of it working on linux 5.15. Give it a try: linuxKernel.kernels.linux_5_15. If it’s a software issue, you may not entirely be out of luck and a kernel update could fix it in a few months or years.

Looking at the number of disparaging reports on that issue makes me think it’s a lot of users reporting similar hardware or configuration problems, rather than a genuine issue; at the very least it seems difficult to get a signal from all the noise. If it is hardware failure, this laptop won’t get fixed. I’d personally return it if reverting to an older kernel fails.

For Linux laptops, lenovo is my go to at the moment, but check the nixos-hardware repo before you buy - doesn’t constitute official support, but if there’s anything major wrong with a laptop you should be able to tell from commits, comments and issues. Note also how overrepresented lenovo is there :wink:

If you fix your laptop, don’t hesitate to add a folder for it.

I tried linuxKernel.kernels.linux_5_15 but same problem sadly :frowning:

Thanks for the other suggestions though! I will check it out, and if I fix it definitely add it to the repo!

Sadly I was unable to fix this wifi chip.

However, it was very easy replacing it. So now I have an AX200 chip, which seems to work perfectly (has now for about half an hour, much longer than the original wifi chip did, and I was able to just use the default kernel for Nixos 21.11, which I believe is 5.10).

1 Like