Missing bootloader from Gnome GUI install

I’m trying to install NixOS on Lenovo X1 Carbon Gen 10, but it appears that the default bootloader settings in the Graphical ISO image do not work as expected.

I’m using nixos-gnome-22.11.1629.2f9fd351ec3-x86_64-linux.iso.

I’m able to run the GUI to create the necessary partitions and install NixOS, and once the install is done, my configuration.nix looks like this:

# Edit this configuration file to define what should be installed on
# your system.  Help is available in the configuration.nix(5) man page
# and in the NixOS manual (accessible by running ‘nixos-help’).

{ config, pkgs, ... }:

  imports =
    [ # Include the results of the hardware scan.

  # Bootloader.
  boot.loader.systemd-boot.enable = true;
  boot.loader.efi.canTouchEfiVariables = true;
  boot.loader.efi.efiSysMountPoint = "/boot/efi";

  networking.hostName = "nixos"; # Define your hostname.
  # networking.wireless.enable = true;  # Enables wireless support via wpa_supplicant.

  # Configure network proxy if necessary
  # networking.proxy.default = "http://user:password@proxy:port/";
  # networking.proxy.noProxy = ",localhost,internal.domain";

  # Enable networking
  networking.networkmanager.enable = true;

  # Set your time zone.
  time.timeZone = "America/Los_Angeles";

  # Select internationalisation properties.
  i18n.defaultLocale = "en_US.UTF-8";

  i18n.extraLocaleSettings = {
    LC_ADDRESS = "en_US.UTF-8";
    LC_MONETARY = "en_US.UTF-8";
    LC_NAME = "en_US.UTF-8";
    LC_NUMERIC = "en_US.UTF-8";
    LC_PAPER = "en_US.UTF-8";
    LC_TELEPHONE = "en_US.UTF-8";
    LC_TIME = "en_US.UTF-8";

  # Enable the X11 windowing system.
  services.xserver.enable = true;

  # Enable the GNOME Desktop Environment.
  services.xserver.displayManager.gdm.enable = true;
  services.xserver.desktopManager.gnome.enable = true;

  # Configure keymap in X11
  services.xserver = {
    layout = "us";
    xkbVariant = "";

  # Enable CUPS to print documents.
  services.printing.enable = true;

  # Enable sound with pipewire.
  sound.enable = true;
  hardware.pulseaudio.enable = false;
  security.rtkit.enable = true;
  services.pipewire = {
    enable = true;
    alsa.enable = true;
    alsa.support32Bit = true;
    pulse.enable = true;
    # If you want to use JACK applications, uncomment this
    #jack.enable = true;

    # use the example session manager (no others are packaged yet so this is enabled by default,
    # no need to redefine it in your config for now)
    #media-session.enable = true;

  # Enable touchpad support (enabled default in most desktopManager).
  # services.xserver.libinput.enable = true;

  # Define a user account. Don't forget to set a password with ‘passwd’.
  users.users.mclare = {
    isNormalUser = true;
    description = "MClare";
    extraGroups = [ "networkmanager" "wheel" ];
    packages = with pkgs; [
    #  thunderbird

  # Enable automatic login for the user.
  services.xserver.displayManager.autoLogin.enable = true;
  services.xserver.displayManager.autoLogin.user = "mclare";

  # Workaround for GNOME autologin: https://github.com/NixOS/nixpkgs/issues/103746#issuecomment-945091229
  systemd.services."getty@tty1".enable = false;
  systemd.services."autovt@tty1".enable = false;

  # Allow unfree packages
  nixpkgs.config.allowUnfree = true;

  # List packages installed in system profile. To search, run:
  # $ nix search wget
  environment.systemPackages = with pkgs; [
  #  vim # Do not forget to add an editor to edit configuration.nix! The Nano editor is also installed by default.
  #  wget

  # Some programs need SUID wrappers, can be configured further or are
  # started in user sessions.
  # programs.mtr.enable = true;
  # programs.gnupg.agent = {
  #   enable = true;
  #   enableSSHSupport = true;
  # };

  # List services that you want to enable:

  # Enable the OpenSSH daemon.
  # services.openssh.enable = true;

  # Open ports in the firewall.
  # networking.firewall.allowedTCPPorts = [ ... ];
  # networking.firewall.allowedUDPPorts = [ ... ];
  # Or disable the firewall altogether.
  # networking.firewall.enable = false;

  # This value determines the NixOS release from which the default
  # settings for stateful data, like file locations and database versions
  # on your system were taken. It‘s perfectly fine and recommended to leave
  # this value at the release version of the first install of this system.
  # Before changing this value read the documentation for this option
  # (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
  system.stateVersion = "22.11"; # Did you read the comment?


I’ve tried incorporating the hardware specific changes for my machine from this file, and before restarting my entire machine (so still within the ISO) attempted to run nixos-rebuild switch to incorporate those small changes.

However, I immediately hit a wall getting the following:

building Nix...
building the system configuration...
Warning: do not know how to make this configuration bootable; please enable a boot loader.
activating the configuration...
setting up /etc...
reloading user units for nixos...
setting up tmpfiles
the following new units were started: systemd-ask-password-console.path

configuration.nix seems to indicate that there is a bootloader, but all of the troubleshooting information I can find seems to think that the bootloader I should have is grub, rather than systemd-boot.

If I mount the partition that NixOS says is my bootloader (/dev/nvme0n1p1), and run bootctl --path /mnt/boot status; echo $? I get that the partition is not a bootloader.

fdisk -l indicates that the type of /dev/nvme0n1p1 is an EFI system.

If I restart the computer and boot into NixOS from the Linux Boot Loader (that is what the Lenovo says it is, rather than a NixOS Boot Loader), NixOS will start to load up but ultimately stall and just show a blinking white underscore in the left upper corner of the screen. Nothing every happens after that.

I’ve not used the GUI, and I’m fairly new to nixos, but some thoughts…

If you look in hardware-configuration.nix you should find an like this:

fileSystems."/boot/efi" =
{ device = “/boot/efis/efiboot0”;
fsType = “none”;
options = [ “bind” ];

which sets up the fstab

I also have this sort of entry (may be a red herring…)

fileSystems."/boot/efis/efiboot0" =
{ device = “/dev/disk/by-uuid/0F6E-9A01”;
fsType = “vfat”;

Your boot-loader config looks OK in the config (mine is similar)

Armed with these, I have salvaged broken boots using a usb install and mounting the required disks (/mnt) and commands such as

nixos-generate-config --root /mnt

(generates that hardware-configuration.nix without affecting configuration.nix or any other .nix files in /etc/nixos) and

nixos-install -v --show-trace --root /mnt
which will do an install using the configuration.nix you already have.

Having broken systems with GRUB (and systemd boot just yesterday) I feel your pain with bootloaders…

This sounds like you’re trying to run a nixos-rebuild on the iso. As in, using the iso’s configuration.nix to generate a new version of the live environment. That’s not going to work.

If you want to alter the installed config after install, you can just run nixos-install again, assuming everything’s still mounted.

I’m running nixos-rebuild only once I’ve mounted the new nixos partition.

Based on this documentation

mount /dev/[root partition] /mnt
mount /dev/[boot partition] /mnt/boot

In my case, my root partition is /dev/nvme0n1p5 and my boot partition should be /dev/nvme0n1p1.

I currently cannot successfully boot into the NixOS partition due to the suspected issues with the bootloader, so I’m having to edit configuration.nix in /dev/nvme0n1p5 which is mounted at /mnt while running the ISO.

I’ll try out running nixos-install after making the model specific changes and see if that makes any difference.

nixos-rebuild operates on the system it is run from. Unless you use nixos-enter to get inside the final system rather than the live environment, you’re rebuilding the live environment.

However, using nixos-install is preferable to using nixos-rebuild inside nixos-enter.

1 Like

Great! I finally have some progress.

I can see after running nixos-install -v --show-trace (and mounting the NixOS drive at /mnt, that new packages are being downloaded related to the graphics cards drivers on my machine. However, it still hits a snag at the end about the bootloader…

If I mount the boot drive using mount /dev/nvme0n1p1 /mnt/boot, I get

installing the bootloader...
setting up /etc...
Failed to check file system type of "boot/efi": No such file or directory

If I mount the boot drive using mount /dev/nvme0n1p1 /boot, I get

installing the boot loader...
setting up /etc...
File system "/boot/efi" is not a FAT EFI System Partition (ESP) file system.

If I run

$ chroot /mnt
$ nixos-install -v --show-trace

I get

mount point /mnt doesn't exist

So nixos-install appears to want the nixOS partition mounted at /mnt and the bootloader partition mounted at /boot.

fdisk -l indicates:

Device                   Start               End       Sectors    Size   Type
/dev/nvme0n1p1           2048             534527        532480    260M   EFI System

findmnt indicates (when I mount the boot drive at /boot:

/boot    /dev/nvme0n1p1     vfat         rw,relative,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro

so I’m at a loss as to why the boot drive isn’t properly formatted. I’ve also tried reformatting the boot drive by running

$ mkfs.fat -F 32 /dev/nvme0n1p1 

after unmounting the boot partition, but it still doesn’t work (still error with mounted at /boot that File system "/boot/efi" is not a FAT EFI System Partition (ESP File System) and fdisk and findmnt output are the same.

I don’t know if the issue is that there is a second Microsoft boot partition in the next slot (/dev/nvme0n1p2) but it seems like it shouldn’t be an issue. When I first used the GUI, it said that it was setting up a fat32 partition at /dev/nvme0n1p1 with mount point /boot/efi.

Firstly, you keep talking about /boot being the ESP, not /boot/efi. Also, I’m not sure if you can even use systemd-boot with an efiSysMountPoint different from /boot. I would remove this line altogether, as afaik it’s only useful with grub, and the default is /boot.

Secondly, all these paths are relative to /mnt. They’re the paths on the final system, not the live environment. So you should be mounting the ESP on /mnt/boot, not /boot.

boot.loader.efi.efiSysMountPoint = "/boot/efi";

That line was automatically generated when I used the GUI.

Commenting it out and running nixos-install again has finally produced a build that I can log into. Unfortunately the bootloader no longer has my windows partition listed, but since I have a windows bootloader on another partition, I can still boot into it from hitting F12 when the computer starts up.


Or not, now running nixos-rebuild switch while in the live environment I can finally get into is complaining about the boot partition again :man_facepalming:

File system "/boot" is not a FAT EFI System Partition (ESP) file system.
systemd-boot not installed in ESP.
No default/fallback boot loader installed in ESP.