Missing gui on virtualbox installation from iso

I tried installing nixos on virtualbox. When choosing the installer from the boot menu I got the prompt saying I should run sudo systemctl start sshd , then set the password for either root or nixos user and then run sudo systemctl start display-manager.

The last command should start the gui interface but it fails silently for me.
BTW I am on ubuntu 18 and virtualbox is version 5.2.42 if that helps

1 Like

I ended up following instructions provided here and managed to install nixos nixos-wiki/Installing NixOS in a VirtualBox guest.page at 1815403202a4f03eca22f5c30e8f77fbdc996f08 · deepfire/nixos-wiki · GitHub

IMHO, there is basically no use in starting the desktop interface on the installer iso. NixOS doesn’t have a graphical installer, and therfore the only thing you would do with this desktop environment is opening a terminal and install nixos via cmdline.

The dektop gives you the capability of opening a browser window with the nixos manual and a terminal at the same time. That was it :wink:

Yeah, I assumed there will be the option to install once gui is running. I wanted to dual boot with ubuntu but ended up somehow screwing up my partitions and now I am on nixos :slight_smile: