Missing icon in Gnome

I can launch librewolf from the terminal but I cant see the icon for this in Gnome.
Looking around I see this solution on youtube:

> sudo ln -s ~/.nix-profile/share/applications/* /usr/share/applications

Is this the best solution (and if so how do I add to my config)?
Cant be a good solution for a multi-user system?
I am using HM but no flakes yet.

I added

  programs.librewolf.enable = true;

But needed to logout to take effect.

This is a well-known issue. As you found out you need to re-log in.