Mounting of camera not working (gphoto2, Canon camera)

So, I have been trying to mount my Canon 500D, but not having much luck. I have tested on other distros, and Darktable has always been able to mount the camera. I have also tested gvfs with gvfs-gphoto2, and been able to mount it in pcmanfm on other distros. Alas, I have not been able to do this in NixOS

So far, I have:

  • Added myself to “camera” group
  • services.gvfs.enable = true;
  • programs.gphoto2.enable = true;
  • Installed Darktable as a system package
  • Installed gphoto2, gphoto2fs and libgphoto2 as system packages in addition to aforementioned steps.

Despite these steps, neither pcmanfm, gphoto2 cli nor Darktable can see the camera and mount it.

Anybody know steps to fix this? Would be much appreciated, thanks

This rings a bell.

This is kinda related,

but not exactly, this was fixed.

Maybe you can provide logs, and nixos version, and just run some of the utils from the command line and see if it’s spits out any good logging? (some times they do, sometimes they don’t).

I don’t have a cannon 500D to reproduce the problem it,but i’d like one. I wonder if it’s DBUS shenanigans (too)…

Hopefully we can get you working.

And you’ll be able to upload all the photos from the nix user group meetings you’ll attend and upload them to :wink:

Hi, thanks for the reply

I’m on 22.11, which is also the stateversion.
I made a post on reddit as well, and someone there said their camera could mount when using GNOME. So I tried using GNOME, and lo and behold, it worked. So my theory is, that I was missing some dependency in my config, which comes with GNOME by default.

Sorry I can’t shine a light on the specific issue, if anybody stumbles upon this thread in the future

1 Like

I’m on KDE and I also experience issues with MTP on NixOs but with my phone (after the KDE fix it worked like once or twice and then it failed again and now it’s really hard to get MTP working for me… ever with android-file-transfer that was working really reliably before).

Have you tried android-file-transfer by any chance?

I am currently experiencing the same issue, the camera is not detected under NixOS, but when I plug it into my Laptop, which is running Fedora, the Camera just popes up in the file-browser. I therefore suspect that the issue lies in NixOS. Your solution, to use Gnome is not applicable, because I am running the Gnome version of NixOS…