Mp4 previews with spacebar


I am trying to make previews of mp4 videos work on pressing spacebar (like with images). After surfing the net I tried several solutions, like adding gst_all_1.gstreamer, gst_all_1.gst-plugins-bad, gst_all_1.gst-plugins-ugly, gst_all_1.gst-libav, ffmpegthumbnailer to my configuration.nix, but to no avail.

anyone has already found a working solution?
Thanks :slight_smile:

Pressing spacebar where exactly?

After selecting a file on gnome files

That is responsibility of Sushi and it should already work. Perhaps you are on stable, which does not have

Indeed I am on stable. I removed all the programs listed above, and followed to add the unstable version of gnome.sushi and that resolves the problem after reboot. thank you very much!

OT: How “unstable” are the versions in the unstable channel?

It is mostly just unstable in the sense that new versions of software will appear, breakage will occasionally appear but it tends to not be a problem thanks to rollback (see e.g. this discussion). Maybe using the same terminology as LibreOffice does (unstable → fresh, stable → stale still) would be more fitting.

1 Like

The main difference is that with stable you get a set of release notes every 6 months that tell you all the things that may break your system if you update to the next version. Within those 6 months, upstream tries its hardest not to break anything.

This means you only have to fix things once every 6 months, instead of potentially every time you update. That’s the idea behind all stable release distros. It’s less risky with NixOS, since you can always roll back anyway, but you still might not want to be forced to fix something if there’s a critical security-related update.

Which you end up preferring is personal taste. Perhaps it’s less important for personal computers, since you don’t need to meet potential regulatory or contractual requirements… But personally I like always being able to update.

Unstable doesn’t make the guarantees required for this. But indeed, it usually takes a little longer for stable to get updates or fixes (looks like @jtojnar backported the fix after reading this), I find that it’s rare for this to be more than a week or so, though, and for anything critical it’s usually much less.

And if you can spot a fix yourself, backporting them isn’t hard.


Can you post a working configuration? I’m having sushi since beginning, but preview never worked for me at all.

I’m still new to NixOS & have a lot of stuff on my work; for now I am sticking to the stable configuration. I have my configuration spreaded across several files; below is the minimum example:

{ config, pkgs, ... }:

  unstableTarball = fetchTarball;
  nixpkgs.config = {
    packageOverrides = pkgs: {
      unstable = import unstableTarball {
        config = config.nixpkgs.config;

  environment.systemPackages = with pkgs; [


Please let me know if it works; otherwise I can collect the whole of the files ogether, but I am still working for it and is still far from complete

If you use GNOME Shell, Sushi should just work out of the box:

Are you using unstable NixOS? Do you use Nautilus and are pressing Space key while having a file selected? Do you see anything in the systemd journal when you do that?

I’m not using gnome shell. I’m on sway on unstable.

I just checked journalctl -f and indeed there’s an error:

Oct 26 02:20:01 nixos-t14s org.gnome.NautilusPreviewer[179078]: EGLDisplay Initialization failed: EGL_NOT_INITIALIZED
Oct 26 02:20:01 nixos-t14s dbus-daemon[2432]: [session uid=1000 pid=2432] Successfully activated service 'org.gnome.NautilusPreviewer'
Oct 26 02:20:01 nixos-t14s .org.gnome.Naut[179078]: cannot open display:
Oct 26 02:20:01 nixos-t14s rtkit-daemon[163217]: Supervising 0 threads of 0 processes of 0 users.
Oct 26 02:20:01 nixos-t14s rtkit-daemon[163217]: Supervising 0 threads of 0 processes of 0 users.