Mpd can't find any music in musicDirectory

Hello. I have been trying to setup services.mpd on nixos 22.05 without any luck so far. I can’t get it to find my music. I already tried every possible combination of keys on my keyboard and still, it doesn’t works, I don’t see any point in copying here what I’m doing. I already tried everything I can find on this site, google, duckduckgo, archlinux wiki, etc. Nothing works.

Depending on the particular solution I’m trying, sometimes journalctl -u mpd complains about folder permission, and sometimes it doesn’t. When there is no error in there, since I have music (with the right permission) in the folders i’m pointing mpd to I guess it should read it?

There is any working example? I don’t care how, I just want it running, even with the music in the default /var/lib/mpd directory, with root user and no password -.-

Just verifying here: You did initiate a database update, right? (ctrl-u in ncmpc or mpc update --wait on the CLI)

Hosted by Flying Circus.