Mutt fails to store certificates permanently

This one drives me mad for a long time, anyone managed to store certificates permanently using mutt?

Description of problem:
When sending emails with, mutt requires to accept the unknown gmx certificate at every new start of mutt. Mutt does not offer the option to save the certificate, only options offered are reject/accept once.
A quick google search indicates this to be a common problem, but the solution to create a ./mutt/certificates and setting the mutt variable certificate_file=./mutt/certificates does not work. This problem does not occur on fedora/debian. Diffing the debian mutt package, debian sets the ssl_ca_certificates_file= variable. According to this mutt bug report, this variable is only available for mutt compiled with gnutls:
ssl_ca_certificates_file: unknown variable (#30) · Issues · Mutt Project / mutt · GitLab
Both debian and fedora mutt package are compiled with gnutls flag, and both don’t have this bug.
Both the Arch and Nixos mutt are compiled without the gnutls flag and both present this bug.
Gentoo allows compiling with gnutls flag
I’m guessing same problem happens with neomutt. Note Arch compiles neomutt with gnutls, nixos does not.

Anyone found a solution?