Need help configuring xmonad as my window manager


#1

After I got a window manager to display, I figured it would be straightforward to go the last mile and get xmonad configured. However, after modifying my configuration.nix, I always still boot into the xterm window manager. Does anyone see an obvious problem with my configuration?

I have saved the file, run nixos-rebuild switch and then rebooted. Booted sends me to the xterm window.


#2

Clever on IRC helped me.

  1. Set services.xserver.desktopManager.xterm.enable = false
  2. Add rxvt_unicode to system packages.

#3

Yes, that is a bit unintuitive, I ran into that problem awhile ago aswell.

That reminds me that I wanted to document that behavior better/change it to something more self explanatory. :slight_smile: