Neovim :checkhealth problems


health#nvim#check
========================================================================
## Configuration
  - OK: no issues found

## Performance
  - OK: Build type: Release

## Remote Plugins
  - OK: Up to date

## terminal
  - ERROR: command failed: infocmp -L

  - INFO: $VTE_VERSION='6401'
  - INFO: $COLORTERM='truecolor'

health#provider#check
========================================================================
  - ERROR: Failed to run healthcheck for "provider" plugin. Exception:
    function health#check[21]..health#provider#check[4]..<SNR>101_check_ruby[15]..<SNR>101_system, line 11
    Vim(let):E903: Process failed to start: no such file or directory: "/bin/bash"

What can I do about it? What would not work if I don’t fix this errors?

Proper solution:
A) Substitute /bin/bash with store path during plugin build
B) Create a PR to the plugin repo to use /usr/bin/env bash instead

hacky solution:
Do something similar to this nixfiles/base-desktop.nix at 6a5d3cd5ea4c4a75481ef28d9d66d4241785beee · gytis-ivaskevicius/nixfiles · GitHub for /bin/bash

Can you provide some code? I don’t understand what should I do with this line:

  systemd.tmpfiles.rules = [
    "L+ /lib64/ld-linux-x86-64.so.2 - - - - ${pkgs.stdenv.glibc}/lib64/ld-linux-x86-64.so.2"
  ];

Rewrite it in a way that it doesn’t link the ld-linux but bash instead.

  systemd.tmpfiles.rules = [
    "L+ /bin/bash - - - - ${pkgs.bash}/bin/bash"
  ];

Should suffice. Though this is really option Z, please try B first and use A to mitigate until the fix has landed.

1 Like

Do you mean this plugin? GitHub - neovim/neovim-ruby: Ruby support for Neovim

Hosted by Flying Circus.