Neovim configuration with home-manager

Hi guys o/

Recently I’ve been annoying by the neovim configuration in my home-manager. I did wish set the gruvbox colorscheme, but without the background color. Ever i try make this on my config, the background still keep there. I tried all possible ways and not works.

I left a specific file for this, and for now this is the code:

{ config, pkgs, ... }:

  programs.nvim = {
    enable = true;
    vimAlias = false;
    plugins = with pkgs.vimPlugins; [
    extraConfig = ''
      colorscheme gruvbox
      :hi Normal guibg=none ctermbg=none
      :hi NonText guibg=none ctermbg=none

Someone can help?

1 Like

I am having the same problems, and I found this wiki page, it isn’t much and I still haven’t gone through it, but it might help you out.

You tried programs.neovim instead of programs.nvim ?

Just watch this video to setup your neovim config with lua. The video basically boils down to this: you install ur neovim plugins using nixos but source your lua files to configure it.

1 Like