New install problem

Trying to install for first time.

On Asrock 4x4 mini 4800U

Ran bunch of distros, about 30 LOL, in last 3 weeks on it, so hardware is OK.

Iso Installation stops after “reached target Graphical Interface”

It just stops on blinking prompt.

Anything I should try?

It’s been a while since I had any issues with this and I’m by no means an expert, but could it be related to the modesetting? You may have tried that already, but I seem to remember having to use the nomodeset kernel param back when I first installed NixOS a few years back. Have you tried that?

Could you make a screenshot? There’s likely other relevant information in the log.

Will try it now, screen is blank when it stops with just blinking underline.

Nothing happens, I’m missing something.

Missing intel integrated graphic driver?

It’s an AMD CPU 4800U.

Did you try @thomas’s suggestion to use nomodeset. If not, that may very well be it.

Tried nomodeset, same results.

Thinking its some bios issue on this, I’ve started experiencing same issues with other distros.

I’m gonna try again probably tomorrow.(today)