Nix bash - locale settings # perl: warning: Setting locale failed

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "en_US:de:es",
        LC_ALL = (unset),
        LANG = "en_DE.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").

de and es were added via plasma config UI

How to set this correctly into the nixos configuration?

  • and how to test the config before switching (I would mind to get the system state messed up)?

Similar to your other question you can quickly search NixOS options on the web.

I don’t know whether setting those options will resolve your issue or not, and I’m not sure how to test without switching. That said, rollback is easy with NixOS.

Hello @austin

i18n.defaultLocale sets which of the locale variables (LC_MESSAGES)?

and so all others have to be/can be set via i18n.extraLocaleSettings?

Would this be the exact format? To me it seems like a format mix?


How to test before switching that this is not messing up the system?

# Select internationalisation properties.
  i18n.defaultLocale = "en_US.UTF-8";

is an example of the format used in configuration.nix



is also interesting for you


here an article about locales in general

1 Like