Nix-prefetch constantly complains about disabled feature `flakes`

Not even when I make sure this configuration is enforced with an environmental variable:

[nix-shell:~]$ NIX_CONFIG='extra-experimental-features = flakes' nix-prefetch fetchurl --urls --expr '[ ]'
       … <borked>

         at «none»:0: (source not available)

       … in the left operand of the update (//) operator

         at /nix/store/2qs4049i0kihlwva9hxk5ywiqk5bigzn-nix-prefetch-0.4.1/lib/nix-prefetch/prelude.nix:3:46:

            3| let prelude = with prelude; import ./lib.nix // {
             |                                              ^
            4|   fetcher = if orig.fetcher == null || elem orig.fetcher.type [ "file" "attr" ]

       (stack trace truncated; use '--show-trace' to show the full trace)

       error: experimental Nix feature 'flakes' is disabled; use '--extra-experimental-features flakes' to override

[nix-shell:~]$ nix-prefetch --version

How to enable the feature? Thanks.

Found a solution: `nix-prefetch` is broken without passing `extra-experimental-features` options on every invocation · Issue #51 · msteen/nix-prefetch · GitHub