Nix-shell --pure disables backspace in shell

I have a shell.nix containing

let
  pkgs = import <nixpkgs> {};
in pkgs.mkShell {}

when I run it with nix-shell --pure, I get dropped into a bash session but backspace doesn’t work. What’s happening and how can I fix it?

Does the same thing happen when you are otherwise in a bash shell? Because if you configure your keyboard configuration in xserver only, it wont propogate to the terminal. I guess you could add fish/zsh to shellHook

let
  pkgs = import <nixpkgs> {};
in pkgs.mkShell {
  shellHook = '' 
    ${pkgs.fish}/bin/fish
  '';
}

and also try if setting useXkbConfig to true helps with getting xserver layout into the terminal.