/nix/var/nix/daemon-socket/socket: Permission denied

Hey! At my university, we just convinced systems to install Nix on one server that my group uses. Unfortunately, the installation seems defunct, as we’re getting this:

~$ nix-shell -p hello --run hello
error: getting status of /nix/var/nix/daemon-socket/socket: Permission denied

Google turns up a number of bug reportrs around /nix/var/nix/daemon-socket/socket but none looks exactly like what we have (Permission denied).

The server is administered by them (we don’t have sudo), so debugging it a bit annoying, but I’m open to any suggestions because we’re completely lost. Thanks!

1 Like

Do you know what linux this is, and how they installed it? I see a number of threads out there mentioning this when people have installed Nix with their system package manager. Looks like quite a few threads are about Alpine.

The Nix manual discusses the mechanism they’re probably using: Multi-User Mode - Nix Reference Manual

If this sounds right, your user or users likely need to be added to the nix-users group.

1 Like

Thanks! This was our guess too because the socket belongs to that group. We’re on getting them to add us to that group.

The distro is Ubuntu. I hope their way of doing things won’t bring other surprises. But I’m not very hopeful because piping to sh is a so much more tried method that I’d expect it to be orders of magnitude more reliable…

(I’ll mark this as solved once our admins add us to the group and we can check that it works…)

1 Like

It did help, thank you again!

1 Like