Nixops still not working on my Mac


#1

Very frustrating. I’ve spent the whole week trying to work around a bug that got pushed to nixpkgs. Here is what I am doing now.

I installed an old version of nix by sh <(curl https://nixos.org/releases/nix/nix-2.1.2/install)

I fetched an old version of nixpkgs (nixpkgs-18.09) and use that for nix-env( -f ~/projects/nixpkgs-18.09). I load nixops-1.6 from that and it still has a bug that was introduced well after the date of those versions. (Calling testing.nix without required argument ‘pkgs’). How can I be seeing the changes that introduced the bug? How can I get back to the version I was using last week before I took in updates?


#2

Have you tried this?
nix-channel --rollback
Each execution rolls back one run of nix-channel --update.


#3

I thought I was reinitializing from scratch. Do the old channel updates stick around?

I tried it and got an error message “no generation older than the current (1) exists”.


#4

If you threw away /nix and possibly ~/.nix* (careful, check the files first), that should be good enough. I don’t have any experience with Nix on Mac OS, though, so I cannot really help you with the Mac OS part.