NixOS boot process fails on Step 2


so I just wanted to switch from Arch Linux to NixOS. I installed NixOS with a live boot medium. For some reason, I forgot to wipe my arch installation. I used the nvme0p1 for the linux filesystem… I commented out some of the things in the config file related to the user. Explicitly, I renamed “alice” to my actual name and used some other things from the generated default config. Then I used nixos-install to complete the boot process.

When I now reboot, I can select either NixOS, arch or archlinux fallback. Which is obviously due to the fact that I forgot to wipe arch linux out. When selecting Arch, I get prompted with a login screen. I tried all things I setup, so root and the password I set, my name and the password I set and so on. Basically tried all sensible combinations. The same thing boots up when running arch fallback. When I select NixOS, I get the error on NixOS stage 2: Failed to load I wanted to install nix from scratch again, but for some reason my iso image doesn’t get detected anymore. Not sure what to do now. I’m stuck. Any help is much appreciated.

first step would be to redownload the iso image and write to usb
my guess is you made a mistake when mounting the drives

Ok I’ll do that first. Thanks