NixOS Gnome: Remove Xterm, Tour and Manual?

Hello I tried everything to uninstall Xterm, to no avail … Same with Tour ( gnome-tour?? ). And now I am a little frustrated and gave up quick when a search for a nixos-manual failed.

I tried
services.xserver.desktopManager.xterm.enable = false;
and disabled CUPS

I tried …gnome.core-utilies.enable = false;
env…gnome.excludePackages = gnome-tour …

Does anybody know?

  • Since has been merged, it is possible to not install GNOME Tour using the following NixOS option: environment.gnome.excludePackages = [ pkgs.gnome-tour ].
  • The installation of NixOS manual is controlled by documentation.nixos.enable NixOS option.
  • CUPS should be disabled by default.
  • For xterm you need services.xserver.excludePackages = [ pkgs.xterm ]; (plus services.xserver.desktopManager.xterm.enable = false; if your system.stateVersion is older than 19.09).

Thanks, but it is hard to figure out this stuff without asking Gurus like you.

You can always grep the nixos directory, that’s what I did.

1 Like


Totally newbee question here:
It’s hard to know “where” or “how” programs are installed by default on Nixos.
For example here, how knowing gnome-tour needs to be exclude in one way and xterm in other way?
Why this choices whereas Firefox, for example, is listed in “configuration.nix” with Nixos22.11 and not them?
What is the best way to install programs on Nixos? Adding in configuration.nix or with “nix-env -iA”?

nix-env -iA is usually discouraged because it mutates state that is difficult to reproduce.

Firefox is listed because it’s a recommended program that isn’t necessarily installed on your system.

The reason that gnome-tour is excluded one way is because of the definition. Sometimes you have to look at the source code for the modules to figure that stuff out.

Some desktop environments and other options automatically enable other options.

Also, you shouldn’t have posted this as a reply to this thread but as a new thread in the Help category.

Thank you for your response, I admit it was not appropriate.
I have so many questions in mind :sweat_smile:

I ended up using this to remove xterm:

services.xserver.excludePackages = [ pkgs.xterm ];