NixOS graphical installer freezes under VMware Fusion

I downloaded nixos-gnome-22.11.3459.884e3b68be0-aarch64-linux.iso and tried to install it under VMware Fusion 13.0.1 on an M1 Mac. However, regardless of which option I select from the menu, I get a spinner that freezes:

I understand others have run it under UTM but I am interested in solving the problem for VMware Fusion.

The minimal / text-based installer does boot.

Is there any way to debug the graphical installer?

can it actually emulate intel instructions inside fusion. I don’t think it can.

If you want visualise intel operating systems, not ARM… then you gonna need an intel mac.

Unless less this is some magic allowing that to happen that nobody has told me about.

NixOS is published as an aarch64 image which should run fine on M1. I am not trying to run the amd64 image.

Hmmm, well it should run, but i’ve got a feeling you problems are with VM Fusion itself.

I could be wrong.

I don’t run apple hardware currently. If it’s no good for Ken Thompson, it’s no good for me.

Smells like a graphics driver issue. Try switching to a tty or using the minimal ISO.

Though honestly, I’d just recommend you to use UTM. I don’t see any reason to use VMWare.

As mentioned the minimal ISO does boot but the manual install process is vastly more complicated than the graphical installer. Is there a TUI for walking through the installation?

I wasn’t able to switch to a TTY with Ctrl-Alt-F1 after the display has frozen.

I admire the UTM project but it is maybe 2 years old and is not the same level of maturity as VMware Fusion with regards to features that are important to me, e.g., snapshots, graphics acceleration, GDB debug stub, etc. Fusion is able to virtualize many other operating systems perfectly well.

If there is a way to capture debug logs and submit them to the issue tracker I would be happy to.

The point of this thread is to troubleshoot the graphical installer failing under a widely-used virtualization program so that NixOS can benefit from improved compatibility, not to seek alternatives that work around but neither identify nor resolve the underlying problem.

1 Like

Have you consider just buying a $100 think , pad with 8gig of ram…

and just install nixos.

Job done, then you can get hacking…

my personal experience with VMware is it actually gives you more problems than is solves.

but your mileage will vary…

please add the logs and bug report to the nix bug tracking on git… It would be appreciated.

thanks for trying it out…

vmware is very expensive, you think it would actually work.

I was able to get through this part and install NixOS by setting the resolution to 720p. I forget the menu option, but the boot loader has an options screen where you can pick between 1080 and 720.

I have an M1 macbook pro with the same version of VMWare.

Thanks for the hint on changing the resolution that potentially solve issues. Oddly it didn’t resolved the issue with vmware fusion but it did with utm! (I’m on m1 platform and having this issue only with apple’s virtualization framework is selected with utm not with qemu)

I was able to get it to work by specifying from the other-linux-5 to fedora linux arm as the OS.

1 Like

I tried Malikiah’s trick of making VMWare Fusion believe it’s Fedora. It didn’t work sadly.