NixOS in Gnome boxes / mouse problem


After installing NixOS in a “Gnome boxes” virtual machine I have the problem, that the mouse pointer is somehow locked to a certain area on the screen or jumping back to the host system, when moving a bit faster. I tired finding some hints here at discourse and via searching the Web, unfortunately without success.

I already tried: different NixOS ISOs, the current beta, the qlx video driver, KDE plasma and Gnome, all with no success.

When using VirtualBox (with the downloadable NixOS image) this problem does not appear, but VirtualBox does not run on Wayland and I’m working with other VMs on Gnome boxes which requires Wayland. I should probably also note that other guests (Fedora or SUSE) do not have the mouse problem.

Does anyone have an idea what I am doing wrong?

1 Like

Could you provide a screencast?
A good program available in nixpkgs for this is peek

nix run nixpkgs.peek -c peek

Hi! Unfortunately it is not so easy to record a screen cast that shows the problem. The uploaded GIF is the best I could create.

Peek is running on the host system. The bigger cursor is the one from the host. It was difficult to switch to the Gnome box (Note: when Gnome boxes is running NixOS the host-cursor disappears inside the box. This is not the case when running other Linux versions in the box).

Once switching to the box running NixOS worked, the small cursor of the box is seen. It then moves downwards, but not to the left side, even though it should. Then I was trying to move it left or right slightly which is hard to see, as the host system cursor appears on the right side of the screen. The latter then is moved to the left side for stopping the recording.


Note: I hope it is OK to upload the GIF as I did and I hope it will show. If it is not OK I’d ask a moderator or admin to remove it. Thank you very much!

Any new on that? I also encouter some strange behaviour with my mouse, but it’s on KDE plasma without any virtualisation involved, but I’ve no idea if it’s nix or a hardware issue. And it’s very hard to pinpoint, because it occurs quite rarely, maybe once or twice a day. I basically have three weird things:

  • sometimes, the mouse clicks when I press some keyboard keys (for example Caps lock (that corresponds to my logicial Ctrl key in fact), or when I press the right/left button. That way, I can navigate, change windows… by simply “clicking” with my keyboard!
  • sometimes, the touchpad “jumps” arbitrarily when I try to click. So instead of clicking, it mouves ~2cm to the top…
  • sometimes, the touchpad is not responsive when I am in the middle of it. So if I smoothly move my finder from left to right, the mouse will move to the right, then stop when my finder is at the center point of the touchpad, and then the mouse moves again when my finder goes out of the center (this later behaviour is quite new)

It usually stays a few seconds, up to one minute, and then it goes back to normal.

I have a Dell Latitude 5500 it it helps.