Nixos-install always fails for me


I’m trying to install NixOS on an old ThinkPad X201 and I can’t get the installer to work, it always fails. Tried two different USB sticks, with two separately downloaded ISOs, and it always fails the same manner. It’s connected via ethernet. Doesn’t seem to make a difference what options I choose in the installer.

Here’s the log:

Any ideas?

error: reading from file: Input/output error

Looks like hardware failure to me, how is your disk doing?

It’s a new-ish (as in bought one or two years ago and hardly ever used) Crucial BX500 240GB SSD.

I don’t had any other issues yet. First time I tried to install NixOS was last week. In the meantime I installed Solus with their Calamares installer without any issues.

Edit: gonna do some disk health analysis soon.

Edit2: GSmartControl extended self test run from GParted live USB completes without error. 42h power on time on that disk btw.

Installing without DE seemed to work just fine…

Tried to install with GNOME before in case anyone is interested to look into it.

Could it be RAM? It also looks like some transient non-nixos-specific error to me.

1 Like