NixOS install stops

I have tried to install NixOS from a bootable USB drive multiple times. Every time, it takes a super long time (stuck at 46%) and then fails.

The latest time, I:

  • booted the computer using the USB (imaged using Rufus 4.5)
  • selected the option that said NixOS 24.05.2150.89c49874fb15 Installer
  • connected to my Wifi (using a USB Wifi adapter because the built-in one didn’t seem to work)
  • Go through the installation wizard (time-zone, keyboard layout, username/password, desktop environment [Plasma], allow unfree software [check])
  • Manually partition (1TB) disk
    1. Delete all other partitions
    2. Create a new partition table (GPT)
    3. Create partition:
      • Size: 600 MiB (I heard the minimum was 512)
      • File System: fat32
      • Mount Point: /boot
      • FS Label: boot (not sure if it does anything)
      • Flags: boot
    4. Create partition:
      • Size: ~150 GB (150,000 MiB) (I heard that 50 GB would be enough, but it didn’t work last time, so I am trying with more)
      • File System: ext4
      • Mount Point: /
      • FS Label: system
      • Flags: root
  • Clicked “Install”
  • The installer did stuff until it got to 46% where it said it was “Installing NixOS”, and then the percent stopped progressing (around 8:50pm)
  • I clicked the terminal icon in the bottom right, and it was doing stuff. Every once in a while it would print something like “copying path X from Y”
  • At around 9:00pm (I think) the screen went black, with only the mouse cursor visible (but still moveable).

That is where I am at currently. I have left it how it is, because it seems like it is possible that it is still working on stuff (last time it said that the installation failed)

Does anyone know what could be wrong?

It may sound like a silly suggestion, but could you try using either a different USB stick (I’m assuming your drive is a stick with flash memory on it, not an external HDD or something like that) or another method of installation?

While I don’t know whether or not your USB stick properly meets the USB spec, I do know that especially cheaper USB stick pull all kinds of tricks that ultimately make them unreliable. So if yours is a cheaper model, it might be worth trying to take it out of the equation.

Yeah, I am using a pretty cheap USB stick. I tried using another one of the same model (because I don’t think I have any “good” USB sticks), and it the same problems happen.